Tower

Help & Support

System requirements

Tower runs on Windows 7 (with SP2 installed) 64bit or later. If you don't run Windows 10, you'll need to have .NET Framework 4.6 installed. An installation of Git is not required since Tower comes with a fully functional Git binary.